Can't start the game in specified resolution

  • #1, by atrusTuesday, 29. August 2017, 11:22 3 years ago
    Hello all,

    Have the following issue on Win 5RC2:

    Using a very simple config.ini:

    FULLSCREEN = no
    RESOLUTION = 1024x576

    However, the game doesn't start in the resolution i specify in the ini file but uses game's default resolution 1920x1080 in a window.

    Forum Fan

    237 Posts


  • #2, by afrlmeTuesday, 29. August 2017, 12:07 3 years ago
    Quick note: it doesn't use any config.ini located in the game root folder. It has to be placed where the messages.log file & save games are stored. If you are using VS5 then check the run game on scene buttons as there's a "go to messages.log" option in the popup menu for those that will open the folder where the files I just said should be located.

    Imperator

    6815 Posts

  • #3, by atrusTuesday, 29. August 2017, 12:10 3 years ago
    Thanks and yes, i have checked the folder, it's ok. It actually reads the config.ini fine, but the Resolution setting is not respected for some reason!

    If anyone could give a quick go on his installation would be great. Using Windows 10.

    Forum Fan

    237 Posts

  • #4, by MachtnixTuesday, 29. August 2017, 14:25 3 years ago
    I remember there is a line "use game resolution = yes/no" in the config. If yes it might overwrite yours. 
    Or: the engine can't handle every solution. But 1024 x 576 is a standard one, it has to work. 

    Thread Captain

    1078 Posts

  • #5, by atrusTuesday, 29. August 2017, 15:06 3 years ago
    Ok, did some more testing:

    - It works ok for an exported game but not when starting the game from the editor.

    Also, when starting from the editor, i can see the following in the messages.log:

    "The command line parameter 'resolution' can only be used in fullscreen mode. Parameter is ignored."

    This is weird, i know that for settting custom resolution you need to be in window mode!


    Forum Fan

    237 Posts

Write post