Cannot Run cannot build

  • #1, by spyros-deliaTuesday, 16. August, 21:37 A month ago
    Hi everybody, I just start create my first demo adventure but.... visionaire denny to run or to build my first scene.
    Following log text appeared.

    =============
    22:32:37.108:Engine Version: 5.1.9.2 (Build 1231 from Build date: Jul 29 2022)
    22:32:37.108:Time needed for preloading game: 1 msec
    22:32:37.108:No config.ini in C:\Users\sdeli\AppData\Local/VisionaireStudio/demoT//config.ini
    22:32:37.110:Using DX11 Subsystem
    22:32:38.161:Initializing graphics interface. Surface size: 640x480, render size: 640x480
    22:32:38.184:Serialization finished. Needed time: 10 ms
    22:32:38.184:SetupParents finished. Needed time: 0 ms
    22:32:38.184:SortLinks finished. Needed time: 0 ms
    22:32:38.184:The game must have one character activated as first character in the game settings
    22:32:38.184:Error loading game data from file 'G:\Visionaire\TestDemo\demoT.ved'
    22:32:38.184:Init failed, could not load game
    ========
    Any advise, suggestions ?

    Thanks
    Spyros

    Newbie

    3 Posts


  • #2, by esmeraldaTuesday, 16. August, 22:06 A month ago
    Looking at the log it seems that you haven't set an active character in the game settings.

    Great Poster

    459 Posts

  • #3, by spyros-deliaTuesday, 16. August, 22:40 A month ago
    Thanks a lot Esmeralda, problem solved !!, by the way when I'm trying to build the game (windows) even I have change the resolution in the properties and/or in the builder section the output is full screen and not in window mode.
    Can you please guide me.

    Thanks,

    Newbie

    3 Posts

  • #4, by afrlmeTuesday, 16. August, 23:05 A month ago
    First things first, you should ideally avoid setting a custom resolution in the build game menu as that is used for scaling your game up or down to another resolution from the default resolution you specified in the main game settings area of the Visionaire Studio editor.

    In regards to fullscreen, that's probably because the config.ini found in the folder that you exported the build to will have the option Fullscreen set to Yes instead of No.

    Also I would just like to point out that you do not need to export your game to test it. You can run it directly via the Visionaire Studio editor immediately via run game (F9) or the various other available run game options & you don't have to wait for anything to compile or anything. Also when you run via the editor you can access the developer console & log via the TAB key on your keyboard which can be useful for debugging & various other things, such as toggling conditions, changing values, etc.

    Finally, check the editor options, then navigate to the player tab (final tab) & make sure fullscreen & the activate support for widescreen displays options are both unticked so that the game when run via the editor will launch in window mode.

    Imperator

    7183 Posts

  • #5, by spyros-deliaTuesday, 16. August, 23:10 A month ago

    thanks for the reply, I will made some tests
    Thanks

    Newbie

    3 Posts

Write post