Arthur Chance and The Summoner's Moon - Demo

  • #1, by ianfoxTuesday, 19. March 2019, 00:37 A year ago
    Hi All,

    I've just uploaded the first Demo of my game - 'Arthur Chance and the Summoners Moon' - here:


    I would be very happy to receive any feedback from anyone who takes the time to play it.  


    Also, if anyone has any pointers on getting the HTML5 builds to work I'd love to hear them - I also uploaded the previous files to itch.io, as well as an embedded HTML5 version here:


    (the password is: Potatoes)

    but I can't seem to get it to run!

    Thanks!
    Ian

    Newbie

    24 Posts


  • #2, by esmeraldaTuesday, 19. March 2019, 11:37 A year ago
    Looks fun. I will have a look at the download version later.
    I tried running the html5 version, but after the downloading/prepairing/running I just get a black screen. I know that html5 doesn't support videos. Maybe that's the problem? (no idea if you are starting with a video, just a wild guess)

    Great Poster

    391 Posts

  • #3, by shicoTuesday, 19. March 2019, 16:29 A year ago
    Hi Ian,
    Congrats on your Demo and thank you for sharing it.
    I like the graphics and the general feel of the game, nice work. I still havn't made it out of the first scene yet, but will give it another go later, I'm probably just missing something smile
    If you don't mind I got a couple of suggestions:

    - I would recommend adding "Volume control" at the main menu or in the settings. To avoid having to go to desktop to change the volume.
    - Inside the save/load menu, maybe remove the "Exit" option? it could be just me but when I clicked on it I assumed it will take me a step back to the main menu but instead it exited the game to desktop.
    Maybe have a "Back" or "Main Menu" button instead and make the "resume" button show up only if you are coming from the game if you know what I mean.
    Possible bug? Every time I examine/look at the hallway door it doesn't go pass the sentence he says, I can't skip it or exit the game from that point, it just gets stuck. I had to use the Windows key to exit to desktop. I tried it few times, same result. 
    And since I didn't save the game nor exited from the main menu, my progress was lost. When/how often the game initate the autosave?

    It's not much but hope you find this feedback useful. 
    Best of luck with the rest of the game, look forward to see more.

    Charbel




    Newbie

    21 Posts

  • #4, by ianfoxWednesday, 20. March 2019, 09:21 A year ago
    Thanks for the feedback, von shico. I'll definitely try and implement those suggestions in the next version.

    That's a problem with the bug examining the door - I'm away for a week but I'll take a look at that asap.

    The game should autosave whenever you press escape to see the main menu, and reloads that autosave when you hit 'resume'.

    Let me know if you get any further or need a pointer!

    Ian

    Newbie

    24 Posts

  • #5, by NigecWednesday, 20. March 2019, 14:29 A year ago
    HTML5, Simon updated it recently and its a lot faster,  as esmeralda mentioned, movies aren't supported, also mp3 and 3D.

    You really need to get the text under control in close ups, it can appear all over the place, also over the inventory

    Key Killer

    565 Posts

  • #6, by caligarimarteSunday, 24. March 2019, 17:50 A year ago
    I have played the Demo as far as I could (see Bug-Report below), and first off: I really like the Art and Style, a very neat little Presentation! smile

    However, there were a few Glitches and similar, one of which making me unable to complete the Demo, it seems:
    • Door-Examine breaks the Game (has already been mentioned).
    • Positioning of CloseUp-Texts (has already been mentioned).
    • After using the Hand-Symbol on the charred Hole and getting the Key, the "charred hole" still remains under the Mouse-Cursor afterwards (just an Issue with the saved Object, easy to fix, and ingame it goes away once I have interacted with something else. 
    • The Duration of how long apoken Text will be displayed is very much out of Control: At the Start, I was under the Impression I had to click before a new Line would appear, then the Villain appeared and suddenly I did no longer have to click for each next Line, and the Text would sometimes disappear just a liiittle too soon; later I was never sure when Clicking was necessary or not, but I often noticed that even some very long Lines would disappear, like, a Second after they had appeared -- impossible to read. 
    • Entering the Forest-Room (beautifully designed, by the Way) makes Arthur say a Sentence as Background-Text, but the Text is not going away, and as long as it is not going away, he can still walk around, but no longer use the Verbcoin, open the Inventory, or even exit to the Menu -- the Text even stayed when I left the Room and went to other Scenes. This happened again after I restarted the Game, so I guess with this Bug I cannot possibly finish the Demo (assuming this Room contains anything important, which I do assume). 

    Furthermore, in Terms of Art and Graphics, I cannot criticize much because all of this could be intended Part of the Style, but a few Things I want to point out, albeit just as minor Nitpicks, but please see them as constructive Criticism:
    • The Inventory is strangely not centered. It also has surprizingly few Item-Slots, and adding one more Slot would almost (but not entirely) make it centered.
    • The Arm-Muscles of the Villain are so massively toned, with strong dark Lines and a somewhat odd Shape (yes, it's toony, but even for that, still odd) -- so odd, in Fact, that I actually had Problems recognizing his overall Shape at first; I suggest making the Lines for his toned Muscles not so dark.
    • Arthur has this dead Stare in his Eyes when looking towards the Camera, but only then... it feels kinda creepy. (Well, I guess my own Protagonist has a much deader Stare by default, so I can't really complain.^^)

    But other than that, all is well. I especially like the Animation of that Flag blowing in the Wind (reminds me of the Art in the old Adventure-Game "Die Höhlenwelt-Saga" or maybe "Tlön"), the View outside the Window, and the Forest Room. I wish you good Luck and Success with this Project!

    Forum Fan

    145 Posts

  • #7, by ianfoxMonday, 25. March 2019, 10:42 A year ago
    Hi Caligarimarte,

    Thank you for the useful feedback, I really appreciate it.
    I'll standardise the text durations, I intend to add voices eventually but yes they'll need tweaking.
    You're right about the inventory - I thinka slight redesign might be in order. Also the arm muscles and dead-eye stare should be quick to amend.

    Thanks again, I'll be updating the demo with the various fixes this week.

    Ian

    Newbie

    24 Posts

  • #8, by shicoMonday, 25. March 2019, 14:31 A year ago
    So I just had another go at the demo.

    I managed to get the coin, however after that whenever I look through the "Hole in wall" I lose the inventory/ actions icons. (similar to what Caligarimarte mentioned when entering the forest room) I  had to go back to previous save to fix it (quitting and resuming didn't fix it).

    Avoiding looking through the hole again after getting the coin, I tried to carry on but no luck in finishing the demo, although I assume I collected everything and tried all items combinations everywhere (yup... got to that point in trying to find a solution smile ). Not sure if there was more stuff to  pick up in the treasury room or not. 
    I'm not asking for a walkthough smile ... just wandering if there is still anything I need from there after getting the coin since I can't do anything after that glitch. If not then I guess I keep trying.

    One other thing I was wondering about, are all the items "re-useable" in the demo? 
    Unless it can be re-used I would suggest removing it from the inventory after the first use. Even if it's just for the demo (I'm sure in the full game there will be much more opportunities to re-use items.)

    * concerning the autosave from the last post, maybe consider adding an autosave whenever the player aquires a a new item / or after successful item combination use. Basically anytime you find it suitable to add a "checkpoint" during the game in addition to autosaving when exiting with main menu. One can never know when something will go wrong that could force a crash to desktop.      


    *Edit : never mind I just managed to finish it - there was one last item that wasn't visible at all (seeds)... I only noticed it because it showed the object's name while pointing at it by mistake... smile  



    Newbie

    21 Posts

  • #9, by ianfoxWednesday, 27. March 2019, 17:40 A year ago
    Hi Shico,

    This is great, thank you for pushing through despite the bugs.

    I've fixed/amended the majority of the things you mentioned and will reupload later in the week.  

    Could you clarify what you mean about the seeds though?  Is the image for the pile of seed in the Rainforest room not visible?  I didn't have this issue but perhaps there's another explaination.

    Thanks,

    Ian

    Newbie

    24 Posts

  • #10, by shicoWednesday, 27. March 2019, 19:09 A year ago
    No problem man, happy to help. 

    Yeah, the image of the seeds is not visible, it shows only the object text.




    Newbie

    21 Posts

  • #11, by ianfoxWednesday, 27. March 2019, 22:01 A year ago
    Oh wow.  Very odd.

    The pile of seed is meant to appear after taking the patch off the brown sack.  Not sure why the seed area is present before that happens!

    Good catch.

    Newbie

    24 Posts

Write post