Android Builds not working in versions < 5

  • #1, by dionousThursday, 13. July 2017, 21:44 3 years ago
    Hi all,

    My android build works great on a Android 5.1.1 tablet but not on my 4.4.4 android phone. The error message is:

    "
    SDL Error
    An error occurred while trying to start the application. Please try again and/or reinstall.
    Error: dlopen failed: could not load library "libavformat-56.so" needed by "libsdlmain.so"; caused by cannot locate symbol "atof" referenced by "libavformat-56.so" ...
    "

    I did some search and i've seen that the issue has already been identified:


    I guess it has to do with the video library, any chance to address this? At the moment, it seems the Android builds work great on versions > 5 but not on earlier ones.

    Forum Fan

    238 Posts


  • #2, by dionousSunday, 16. July 2017, 17:34 3 years ago
    just a reminder in case someone has some idea abt this!

    Forum Fan

    238 Posts

  • #3, by SimonSThursday, 27. July 2017, 01:55 3 years ago
    It's not compatible with <5. ffmpeg doesn't work with lower version.

    Thread Captain

    1383 Posts

Write post