Always allow to skip active text - runtime toggle?

  • #1, by andiliddellThursday, 29. January 2015, 00:48 6 years ago
    After setting "always allow to skip active text" in the game properties, can this be toggled off at runtime.

    I'm hiding all interfaces and hiding the cursor but the user can still skip the current cut scene and character text?

    Thanks in advance

    Forum Fan

    178 Posts


  • #2, by afrlmeThursday, 29. January 2015, 01:14 6 years ago
    game.AlwaysAllowSkipText = false
    1


    That won't stop users from being able to skip cut-scenes with ESC though. If you don't want a cut-scene to be skipped (ever) then use hide/show cursor action parts instead of begin/end cutscene action parts. Hide/show cursor is the same as cutscene action part but it will not automatically hide the interfaces, but it will kill all keyboard input until the cursor is shown.

    I believe that it's also possible to disable the ESC key via the key event handler with Lua script. I think you can, but I'm not 100% sure.

    Imperator

    6862 Posts

  • #3, by andiliddellThursday, 29. January 2015, 01:20 6 years ago
    Looking at the data structure on the wiki the following variable says it can be scripted:

    GameAlwaysAllowSkipText

    unfortunately, I can find no simple explanation of how to set this t_Bool .

    Is there a setBool(GameAlwaysAllowSkipText) method?



    Forum Fan

    178 Posts

  • #4, by andiliddellThursday, 29. January 2015, 01:23 6 years ago
    Sorry didn't see your reply.

    game.AlwaysAllowSkipText = false didnt seem to work.
    Hiding the cursor doesn't work either, I can still click to skip the active text from a character.

    Any ideas?

    Forum Fan

    178 Posts

  • #5, by afrlmeThursday, 29. January 2015, 01:31 6 years ago
    You added what I wrote into an execute a script action part? If you are using 4.1 then it should work. The 3.7.1 getObject method would look like this...
    game:setValue(VGameAlwaysAllowSkipText, false)
    1
    2


    It works fine for me. Try testing this out...

    1. have always skip text enabled in the game tab.
    2. run game > check if it allows you to skip during cut-scene or after hiding cursor.
    3. now press "tab" key on you keyboard to open console.
    4. type...
    exec game.AlwaysAllowSkipText = false
    1

    5. press enter (it should say something like success blah blah blah.
    6. press "tab" again to close the console.
    7. now check again & see if you can skip text during cut-scene or after hiding cursor.

    If it's not working, then it could be a bug with the current public build. It's working ok in the team build (1179) that I am currently using.

    Imperator

    6862 Posts

  • #6, by andiliddellThursday, 29. January 2015, 01:37 6 years ago
    Yeah Im on 4.1 full license, thought it might be a bug where its overriding everything?

    I've Actually managed to solve it by moving the begin cutscene action lower down the list after the character change.. and telling it to hide the cursor again after that. This is all on a beginning of scene action, shown in full below.

    The first hide cursor one is totally ignored, and begin cutscene if used first is ignored too it seems.

    Maybe a combination of the change in character, condition check and the other sript execution going on?

    Its solved for now, but weird Ive had to fudge it like that?

    Forum Fan

    178 Posts

  • #7, by afrlmeThursday, 29. January 2015, 01:43 6 years ago
    Bloody nora! look at all those action parts. roll

    Not sure why you are using both hide cursor & cut-scene together. They both sort of cancel each other out.

    Hide cursor on its own is same as cut-scene but it kills key input, but in combination with begin cutscene it allows key input again, or at least it did in earlier builds (not tested it recently).

    P.S: check the message above your last message as I updated that post while you were replying.

    Imperator

    6862 Posts

  • #8, by andiliddellThursday, 29. January 2015, 11:06 6 years ago
    lol... Its a particularly long list of action parts, as its the final cut scene, controlled in engine, rather than just a video smile

    I think the only reason I tend to use begin cut-scene and hide cursor is because of inconsistencies like this.. it seems if I tell it enough times to hide the bloody cursor and stop user input then eventually it does grin

    Forum Fan

    178 Posts

  • #9, by MilenaFriday, 30. January 2015, 16:00 6 years ago
    Hihi, I really think (and do) the same grin.

    Newbie

    74 Posts

Write post